Getting started
It is a good idea to create an account to use Publish as local browser storage is limited and a typical publication with many images will exceed this size fast. Once you have an account, just set a publication name and your publication will be saved as a project with its settings, issues and fonts stored within it. You can have more than one publication project in your account. Being able to share access to a project with other Phrond users is currently unavailable but will be added in the future.
Set the publication up
Open File → Settings for the publication name, issue identifier, byline, page size, margins, section and column spacing, default padding, colors, fonts, base text sizes, and header/footer settings.
Text settings can be used as document tokens, including {{issue-name}}, {{issue-identifier}}, {{byline}}, {{month}}, {{year}} and {{page}}. Tokens are especially useful in headers and footers.
Collating input
The input panel on the left of the screen is a staging space for material that still needs placing. Add text or images by uploading, pasting, or dragging files into a bucket. Incoming content in DOCX format will automatically be stripped of most formatting. Incoming content in PDF format will be flattened into an image. If you need DOCX formatting preserved exactly, convert it to a PDF before importing. This separation is meant for advertisements with complex formatting vs articles that are mostly text. Join the beta program if you have suggestions about this process.
Use the default buckets - Articles, Ads, Images, and Other - to keep incoming material findable. Input items are not the final page content; this is simply a structured holding area for incoming content. Place your input into document sections by dragging them into place when you are ready. Editing content in the document does not change what you have stored in the input buckets.
Create the page structure
Use File → New section to add Full height, Half height, Quarter height, or Flow sections. Select and then right-click a section to change its column layout, resize it, move it, preserve it for the next issue, or delete it.
Flow sections can continue across pages once their content does not fit in one area, and all sections can be manually resized or snapped back to a pre-defined size. This allows you to fully lay out a document before you start adding content to it
Format content
Show the toolbar from View → Toolbar. Select text (or a whole section), then use the toolbar for body and heading treatments, inline formatting, case, size, font, alignment, lists, spacing, padding, borders, and colors.
Use Edit → Autofit when text needs to fit its available area. Autofit line fits a selected line; Autofit text fits highlighted text into its starting column. Autofit is best used when content is almost the correct size, as it works by making small tweaks to padding, font sizes and letter spacing.
Make the next issue
File → New issue freezes the current issue and creates the next active issue. Sections marked Preserve carry their content forward; other section content and input items are cleared for the new issue but the actual size and placement of sections does not change, only the content is cleared. This allows you to re-use a layout from issue to issue.
The previous issue remains available as frozen history. Any tokens within a previous issues are replaced with their values (eg {{month}} becomes "August"), while the new issue retains the raw tokens. If you leave creating a new issue from an old one late and the token values saved in the process are wrong, eg because the month or year has changed, you can still edit previous issues.
Save and export
Your changes will autosave to your account. Signed-out work is kept temporarily in volatile browser storage and will show a warning in the top right of the screen. Sign in to save the publication to your Fern account project.
Use File → Export package (.publish) for a portable backup or transfer. Use File → Export PDF for the print-ready output. PDF output currently leverages the browser's print layout and will later be changed to a stand-alone process. Join the beta program if you have suggestions about this process.
Useful workspace controls
- View → Headers & footers toggles the header and footer regions while you work.
- View → Layout toggles structural layout overlays.
- View → Spacing guides shows measurement guides for spacing and layout.
- Edit → Reset Full/Half Heights recalculates preset section heights from the current page settings - especially useful if you have just changed page margins.
- Edit → Reset all spacing in this section clears spacing adjustments in the selected section.
Still being polished
Publish is a complete single-user workflow but it is a new project and still being polished and tested. It is currently in use to create the Phrond site author's regional Australian small town newsletter. More features are likely to be added but the currrent core functionality won't be reduced, and the entire Publish project is meant to be a relatively simple, easy to use application not a replacement for an advanced desktop publishing system. To be on the safe side during beta, keep a .publish package backup and join the beta program to report any bugs or make suggestions. Standalone versions for Windows, Mac, iPad etc that don't need a subscription are likely to be made available in the future once the web version's functionality stabilizes.